Monitoring Potential Impact from Ongoing AWS Outage

Incident Report for Geico Core

Resolved

The AWS outage has been confirmed to be resolved. Please reach out to Snapsheet Support with any questions.
Posted Oct 21, 2025 - 06:38 UTC

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 17:32 UTC

Investigating

We are continuing to monitor the ongoing AWS outage. As a result of this incident, we are experiencing delays in data warehouse replication. We'll share updates as more information becomes available.
Posted Oct 20, 2025 - 17:29 UTC
This incident affected: Snapsheet Claims (UAT).